SharePoint 2010: Unable to Create Profile Import Connection?

I ran into this problem after rushing through the setup and installation of SharePoint 2010. In short, when trying to create a new import connection for user profiles in SharePoint 2010, nothing happened.

Literally, nothing happened. I filled in the nice form to create a new connection, chose the correct AD containers, but upon hitting OK, the import connections page just said that the query did not return any results, and no connection got created.

So, I ran through the logs (and by gods, I love the new logs) but sadly no help there either. Even when setting the entire SharePoint Foundation section to Medium in the Diagnostic Logging section, I only got a couple of “Entering monitored scope” for _layouts/EditDSServer.aspx when entering the page and right after submitting, the same message for _layouts/MgrDSServer.aspx, but nothing even close to an error message between.

I’ve seen several posts on error messages such as being unable to connect to the database, requiring an IIS Reset, but nothing explaining why I couldn’t even create a new connection.

However, after carefully following the most recent blog post from the Microsoft SharePoint Team Blog and then doing a reverse engineering of the process, I slapped my forehead and delegated the AD “Replicate Directory Changes” permission to the SP Admin account used for setting up the profile connection, and thus solving the problem.

I strongly encourage you to follow the blog post. Well, except their encouragement not to test and play around, though 🙂

.b

Found this article valuable? Want to show your appreciation? Here are some options:

a) Click on the banners anywhere on the site to visit my blog's sponsors. They are all hand-picked and are selected based on providing great products and services to the SharePoint community.

b) Donate Bitcoins! I love Bitcoins, and you can donate if you'd like by clicking the button below.

c) Spread the word! Below, you should find links to sharing this article on your favorite social media sites. I'm an attention junkie, so sharing is caring in my book!

Pin It

Published by

Bjørn Furuknap

I previously did SharePoint. These days, I try new things to see where I can find the passion. If you have great ideas, cool projects, or is in general an awesome person, get in touch and we might find out together.

2 thoughts on “SharePoint 2010: Unable to Create Profile Import Connection?”

  1. I have the exact same issue (or it seems that way). I have tried to use a domain admin account to create the connection; no luck. I have given the Farm Admin account delegation rights in AD, still no luck. Very strange behavior…

  2. Martijn,

    Strange, are you sure you delegated the 'Replicate Directory Changes' to the correct user?

    Also, verify whether the two Forefront* services are running in Windows Services, and if they're not, verify that you have started the User Profile service in SharePoint. Doing the latter will leave the service in a 'Starting' state while everything is set up, but afterwards, the two Forefront services should run.

    .b

Leave a Reply

Your email address will not be published.